PAT-1020 Tree Traversals

1020 Tree Traversals (25分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

代码:

#include <bits/stdc++.h>

using namespace std;
const int maxn = 30;
int n;
struct node{
    char data;
    node* lchild;
    node* rchild;
}BiTree;
int post[maxn], in[maxn];

/*重建*/
node* restore(int postL, int postR, int inL, int inR){
    if(postL>postR)
        return NULL;
    node* root = new node;
    root->data = post[postR];
    int k;
    for(k=inL; k<=inR; k++){
        if(in[k]==post[postR])
            break;
    }
    int numLeft = k - inL;
    root->lchild = restore(postL, postL+numLeft-1, inL, k-1);
    root->rchild = restore(postL+numLeft, postR-1, k+1, inR);
    return root;
}

/*层次*/
int num = 0;
void levelorder(node* root){
    queue<node*> Q;
    Q.push(root);
    while(!Q.empty()){
        node *top = Q.front();
        Q.pop();
        printf("%d", top->data);
        num++;
        if(num<n) printf(" ");
        if(top->lchild!=NULL)
            Q.push(top->lchild);
        if(top->rchild!=NULL)
            Q.push(top->rchild);
    }
}


int main(){
    scanf("%d", &n);
    for(int i=0; i<n; i++)
        scanf("%d", &post[i]);
    for(int j=0; j<n; j++)
        scanf("%d", &in[j]);
    node* root = restore(0, n-1, 0, n-1);
    levelorder(root);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值