HDU - 2795

题目:
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.
Sample Input
3 5 5
2
4
3
3
3
Sample Output
1
2
1
3
-1

代码如下:

#include<iostream>
#include<cstdio>
using namespace std;
#define MAX 200005
int tree[MAX << 2],a[MAX],ans;
void build(int l,int r,int rt,int w)//tree就是选取这个区间里最大剩余的空间
{
    tree[rt] = w;
    if(l == r) return;
    int mid = (l + r) >> 1;
    build(l,mid,rt << 1,w);
    build(mid + 1,r,rt << 1 | 1,w);
}
void query(int l,int r,int rt,int c)
{
    if(l == r){
        tree[rt] -= c;//海报填充了剩余的空间
        ans = l;//标记海报贴的位置
        return;
    }
    int mid = (l + r) >> 1;
    if(tree[rt * 2] >= c) query(l,mid,rt << 1,c);//优先考虑板报的上方位置
    else query(mid + 1,r,rt << 1 | 1,c);
    tree[rt] = max(tree[rt << 1],tree[rt << 1 | 1]);
}
int main()
{
    int h,w,n;
    while(~scanf("%d%d%d",&h,&w,&n)){
        if(h > n) h = n;//长度比海报数量多是没有意义的
        build(1,h,1,w);//建线段树
        for(int i = 1;i <= n;i++) scanf("%d",&a[i]);
        for(int i = 1;i <= n;i++){
            if(a[i] > tree[1]){//最宽的地方也放不下海报,所以肯定没地方能放下
                cout << "-1" << endl;
                continue;
            }
            query(1,h,1,a[i]);
            cout << ans << endl;
        }
    }
    return 0;
}

题意:
一块海报板,给你它的长度和宽度,再给你n张海报,告诉你每张海报的宽度(每张海报的默认长度都为1)。现在要你往海报板上贴海报,优先往上左方向贴,如果这张海报能贴输出贴的位置,不行输出-1.
思路:
这道题可以用线段树去完成。每个区间代表的是这些行里最大的剩余容量(也就是空出来的最大宽度),然后每次都优先往上方贴,利用线段树去进行二分查找,找到了需要把这一段区间的容量减去所贴海报的宽度,注意每次查询时还需进行取最大值的操作。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值