PAT A1047 Student List for Course

PAT A1047 Student List for Course

在这里插入图片描述

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
  • 分析
    A1039的反向输出

  • 思路 1:散列法
    由课程(int)找人(string),输入时记录输入学生的顺序,即学生的编号,用一个char[id][5]记录编号和学生姓名的对应关系,用一个vector,将每个课程的学生编号写入
    遍历查找,将编号转化为姓名输出即可

  • code 1:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string>
#include <vector>
#include <cstring>	//strcmp
using namespace std;
char name[40010][5];
vector<int> query[3000];
bool cmp(int a, int b){
	return strcmp(name[a], name[b]) < 0;
}
int main(){
	int np, nc, select, course;
	scanf("%d %d", &np, &nc);
	for(int i = 0; i < np; ++i){
		scanf("%s %d", name[i], &select);
		for(int j = 0; j < select; ++j){
			scanf("%d", &course);
			query[course].push_back(i);
		}
	}
	for(int i = 1; i <= nc; ++i){
		int len = query[i].size();
		printf("%d %d\n", i, len);
		sort(query[i].begin(), query[i].end(), cmp);
		for(int j = 0; j < len; ++j){
			printf("%s\n", name[query[i][j]]);
		}
	} 
	return 0;
}
  • 思路2: 直接STL

  • T2 code:

#include <bits/stdc++.h>
using namespace std;
vector<vector<string> > mp(3000); 

int main(){
	int n, m;
	scanf("%d %d", &n, &m);
	for(int i = 0; i < n; ++i){
		string name;
		int cnt, t_id;
		cin >> name >> cnt;
		for(int j = 0; j < cnt; ++j){
			scanf("%d", &t_id);
			mp[t_id].push_back(name);
		}
	}
	for(int i = 1; i <= m; ++i){
		printf("%d %d\n", i, mp[i].size());
		sort(mp[i].begin(), mp[i].end());
		for(int j = 0; j < mp[i].size(); ++j){
			printf("%s\n", mp[i][j].c_str());
		}
	}
	return 0;
}
  • T3 code: 下标排序
#include <bits/stdc++.h>
using namespace std;
const int maxn_c = 3000;
vector<int> course[maxn_c];
char find_name[40010][5];

bool cmp(int a, int b)
{
    return strcmp(find_name[a], find_name[b]) < 0;
}
int main()
{
    int np, nc;
    scanf("%d %d", &np, &nc);
    for(int i = 0; i < np; ++i)
    {
        int tnc;
        scanf("%s %d", find_name[i], &tnc);
        for(int j = 0; j < tnc; ++j)
        {
            int cid;
            scanf("%d", &cid);
            course[cid].push_back(i);
        }
    }
    for(int i = 1; i <= nc; ++i)
    {
        printf("%d %d\n", i, course[i].size());
        sort(course[i].begin(), course[i].end(), cmp);
        for(int j = 0; j < course[i].size(); ++j)
        {
            printf("%s\n", find_name[course[i][j]]);
        }
    }
    return 0;
}

  • T4 code:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 2550;
vector<int> ans[maxn];
int Change(char s[])
{
    int x = 0;
    for(int i = 0; i < 3; ++i)
    {
        x = x * 26 + (s[i] - 'A');
    }
    return x * 10 + (s[3] - '0');
}
void Print(int x)
{
    printf("%c%c%c%c\n", x/ 10 / 26 / 26 + 'A', x / 10 / 26 % 26 + 'A',x / 10 % 26 + 'A', x % 10 + '0');
}
int main()
{
    int n, k;
    scanf("%d %d", &n, &k);
    for(int i = 0; i < n; ++i)
    {
        char name[10];
        int nc, id;
        scanf("%s %d", name, &nc);
        id = Change(name);
        for(int j = 0; j < nc; ++j)
        {
            int tmp;
            scanf("%d", &tmp);
            ans[tmp].push_back(id);
        }
    }
    for(int i = 1; i <= k; ++i)
    {
        printf("%d %d\n", i, ans[i].size());
        sort(ans[i].begin(), ans[i].end());
        for(int j = 0; j < ans[i].size(); ++j)
        {
            Print(ans[i][j]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值