hdu2859 Phalanx (DP)

题目链接
Problem Description
Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size nn, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3
3 symmetrical matrix:
cbx
cpb
zcc

Input
There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.

Output
Each test case output one line, the size of the maximum symmetrical sub- matrix.

Sample Input
3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0

Sample Output
3
3

Source
2009 Multi-University Training Contest 5 - Host by NUDT

题意:要你找出最大对称矩阵。
思路:我们枚举(i,j)为矩阵的左下角,定义dp【i】【j】为左下角坐标为(i,j)是最大矩阵大小,我们可以发现dp【i】【j】的状态可以由dp【i-1】【j-1】推出来,dp【i-1】【j-1】的大小来向上向右看看对应元素是否相等,我们向上向右的范围就是前一个矩阵(dp【i-1】【j-1】)的大小推的,所以内部肯定是符合要求的。

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e3+1;
char s[maxn][maxn];
int n,dp[maxn][maxn];
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0) break;
        int ans=1;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;++i) scanf("%s",s[i]+1);
        for(int i=1;i<=n;++i)
        for(int j=n;j>=1;--j)
        {
            dp[i][j]=1;
            if(i==1||j==n) continue;
            for(int k=1;k<=dp[i-1][j+1];++k)
            if(s[i-k][j]==s[i][j+k]) dp[i][j]++;
            else break;
            ans=max(ans,dp[i][j]);
        }
        printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值