There are N little kids sitting in a circle, each of them are carrying some java beans in their hand. Their teacher want to select M kids who seated in M consecutive seats and collect java beans from them.
The teacher knows the number of java beans each kids has, now she wants to know the maximum number of java beans she can get from M consecutively seated kids. Can you help her?
Input
There are multiple test cases. The first line of input is an integer T indicating the number of test cases.
For each test case, the first line contains two integers N (1 ≤ N ≤ 200) and M (1 ≤ M ≤ N). Here N and M are defined in above description. The second line of each test case contains N integers Ci (1 ≤ Ci ≤ 1000) indicating number of java beans the ith kid have.
Output
For each test case, output the corresponding maximum java beans the teacher can collect.
Sample Input
2
5 2
7 3 1 3 9
6 6
13 28 12 10 20 75
Sample Output
16
158
题意: 每个同学手里有不同数量的豆子,围成一个圈。选定连续的m个同学,得到的最多的豆子数。
#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<cmath>
#include<cctype>
#include<stack>
#include<cstring>
#include<set>
#include<map>
using namespace std;
int mapp[210];
int main()
{
int t;
cin>>t;
while(t--)
{
int n,m;
scanf("%d%d", &n, &m);
for(int i=0; i<n; i++)
{
scanf("%d", &mapp[i]);
}
int maxx=0;
for(int i=0; i<=n; i++)//i要从0到n,当i=n时,里面循环是从下标为0开始;
{
int sum=0;
int flag=0;
for(int j=i%n; ; j++)
{
j = j%n;//如果在循环到数组最后一个时,下一个就要从坐标为0开始;
/* if(j>=n)
j = j-n;
*/
flag++;
sum+=mapp[j];
if(flag==m)
break;
}
if(maxx<sum)
maxx=sum;
}
printf("%d\n", maxx);
}
}