骰子涂色(Cubepainting)

We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors.
The cube’s faces are numbered as in Figure 1.
在这里插入图片描述

Since a cube has 6 faces, our machine can paint a face-numbered cube in different ways. When ignoring the face
numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6
characters,where each character is a b, r, or g. The character ( ) from the left gives the color of face i. For example, Figure 2 is a picture of rbgggr and
Figure 3 corresponds to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 , the one changes into the other.
在这里插入图片描述在这里插入图片描述

Input
The input of your program is a textfile that ends with the standard end-of
file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters
give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any
combination of rotations one can be turned into the other. (Reflections are not allowed.)

Output
The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation
as describes above, FALSE otherwise.

Sample Input

rbgggrrggbgr
rrrbbbrrbbbr
rbgrbgrrrrrg

Sample Output

TRUE
FALSE
FALSE

#include<stdio.h>
int main()
{
    char a[20],b[10];
    int sum=0;
    while(~scanf("%s",a))
    {
  	for(int i=6;i<12;i++)
  	{
            b[i-6]=a[i]; 
  	}
  	sum=0;
  	for(int i=0;i<3;i++)
  	{
            for(int j=0;j<6;j++)
            {
    		if(a[i]==b[j]&&a[5-i]==b[5-j])
                { 
     		    a[i]=a[5-i]='0';  
                    b[j]=b[5-j]='1';  
                    sum++;
    		}
                else 
                {
     		     continue;
                }
   	    }
        }
        if(sum==3) 
        {
   	     printf("TRUE\n");
        }
        else 
        {
             printf("FALSE\n");
        }
    }
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

【执珪】瑕瑜·夕环玦

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值