HDU 2199 Can you solve this equation?

题目描述:

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

 

给出的方程在定义域0-100内单调,故简单二分法。注意题目没说y的范围,根据区间判断上下界,出界的数据无法找到答案

注意这道题是函数求值,相应浮点数结果必须要符合题目要求的精度才行

比如这道题是四位小数,那么abs(ans-y)<0.0001

 

 

 

#include <stdlib.h>
#include <stdio.h>
#include <iostream>
#include <queue>
#include <algorithm>
#include <string.h>

using namespace std;

int t;
double y;

double equaltion(double x){
    return x*x*x*x*8+7*x*x*x+2*x*x+3*x+6;
}

int main()
{
    scanf("%d",&t);
    double Max=equaltion(100);
    double Min=equaltion(0);

    while(t--){
        scanf("%lf",&y);

        if(y<=Max&&y>=Min){
            double left=0,right=100;
            double mid;
            while(right-left>=1e-6){
                mid=(right+left)/2;
                double n=equaltion(mid);
                //printf("%f %f %f %f\n",left,mid,right,n);
                if(abs(n-y)<0.0001){
                    break;
                }
                else if(n>y){
                    right=mid;
                }
                else {
                    left=mid;
                }
            }
            printf("%.4f\n",mid);
        }
        else printf("No solution!\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值