Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
思路好想 注意结束条件。
# include <cstdio>
int m, flag;
using namespace std;
void DFS(int x, long long y)
{
if(x >19 || flag ==1)//flag是用来保证当找到这个数时可以,终止这条路,
{
return;
}
if(y%m == 0)
{
flag = 1;
printf("%lld\n",y);
return ;
}
DFS(x+1, y*10);
DFS(x+1, y*10+1);
}
int main(void)
{
while(~scanf("%d",&m), m)
{
flag = 0;
DFS(1, 1);
}
return 0;
}