Roads in the North(树的直径)(暂存)

Roads in the North

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice.
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area.

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1.
Input
Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.
Output
You are to output a single integer: the road distance between the two most remote villages in the area.
Sample Input
5 1 6
1 4 5
6 3 9
2 6 8
6 1 7
Sample Output
22

这道题很奇怪的地方在于多组输入,(大佬说需要Ctrl+z然后怎么怎么着来结束。。。没听懂,所以样例还没运行出来,不过bfs应该是对的)

#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;

int n,m;//n是农场数,m是路的个数
int a,b,cost;//两个农场的位置以及距离(存的时候两个方向都要存)
char d;
int dis[50005];//到每个农场的距离 
int vis[50005]; 
int ed,ans,num;
int head[50005];
struct cow{
	int from;//农场的序号1
	int to;//农场的序号2 
	int next;
	int llng;//距离 
	//friend bool operator<(cow a,cow b){
	//	return a.llng <b.llng ;
	//} 
};
cow e1[100005];
void add(int a,int b,int c){
	e1[num].from =a;
	e1[num].to =b;
	e1[num].llng =c;
	e1[num].next =head[a];
	head[a]=num++;
}
void bfs(int x){
	memset(vis,0,sizeof(vis));
	memset(dis,0,sizeof(dis));
	queue<int> que;
	que.push(x);
	vis[x]=1;
	ans=0;
	while(!que.empty()){
		int u,v,i;
		u=que.front();
		//cout<<"u:"<<u<<endl;
		que.pop();
		for(i=head[u];i!=-1;i=e1[i].next ){
		v=e1[i].to ;
		//cout<<"v:"<<v<<endl; 
		if(!vis[v]){
			
			if(dis[v]<dis[u]+e1[i].llng )
				dis[v]=dis[u]+e1[i].llng;
				vis[v]=1;
				que.push(v);
		//		cout<<"v:::::"<<v<<endl;
			}
		}
	} 
	for(int i=1;i<=n;i++){
	if(dis[i] >ans){
			ans=dis[i];
			ed=i;
		//	cout<<"ans:"<<ans<<" "<<i<<endl;
			}
		} 
	} 

int main(){
	ios::sync_with_stdio(0);
	cin.tie(),cout.tie();
	
	int num=1;
	memset(head,-1,sizeof(head));
	
		while(scanf("%d %d %d",&a,&b,&cost)!=EOF){
			add(a,b,cost);
		add(b,a,cost);
		}
		bfs(1);
	
	bfs(ed);
	cout<<ans<<endl;

	
	
	
	return 0;
}

/*

1 6 13
6 3 9
3 5 7
4 1 3
2 4 20
4 7 2
7 6 67
7 5 76


*/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值