蓝桥杯C之hello world

  1. 一维数组
    类型说明符 数组名 [常量表达式];
    数组中的元素下标是从0开始计算的
  2. 二位数组
    类型说明符 数组名[行数][列数];
  3. EOF(end of file)就是文件的结束,通常来判断文件的操作是否结束的标志。
    EOF不是特殊字符,而是定义在头文件<stdio.h>的常量,一般等于-1;
    除了文件结束,做题遇见最多的是标准输入,但是标准输入与文件不一样,无法事先知道输入的长度,必须手动输入一个字符,表示到达EOF:
while(scanf("%d %d\n",&a,&b)!=EOF){    }
while(~scanf("%d %d\n",&a,&b)){    }
  1. ACSLL码转换成字母,直接
    int a;
    char s=(char)a或者直接输出printf("%c",a);
    题目 1083: Hello, world!

时间限制: 1Sec 内存限制: 64MB 提交: 13160 解决: 6350

题目描述
This is the first problem for test. Since all we know the ASCII code, your job is simple: Input numbers and output corresponding messages.
输入
The input will contain a list of positive integers separated by whitespaces(spaces, newlines, TABs). Please process to the end of file (EOF). The integers will be no less than 32.
输出
Output the corresponding message. Note there is NOT a newline character in the end of output.
样例输入
72 101 108 108 111 44
32 119 111 114 108 100 33
样例输出
Hello, world!

代码:

#include <stdio.h>
#define num 1000
int main(){
	int s1;
	while (scanf("%d",&s1)!=EOF){
		printf("%c",s1);
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值