Buy Tickets (线段树,倒更)

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

有N个人排队,每一个人都有一个val来对应,每一个后来人都会插入当前队伍的某一个位置pos。要求把队伍最后的状态输出。

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i(1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

第一行一个整数N,表示n个人 接下来n行,每行两个整数x和val,表示一个标记为val的人,插入到排在第x位置的人的后面。

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

从前往后,输出所有的val

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

 

#include <iostream>
using namespace std;
const int MAX = 2e5 + 5;
int pos[MAX], val[MAX], ans[MAX], st[MAX << 2];
void PushUp (int rt){
    st [rt] = st[rt << 1] + st[rt << 1 | 1];
}
void Build (int l, int r, int rt){
    if (l == r){                   //不是建空树
        st[rt] = 1;
        return ;
    }
    int m = (l + r) >> 1;
    Build(l, m, rt << 1);
    Build(m + 1, r, rt << 1 | 1);
    PushUp(rt);
}
void Update (int pos, int valu, int l, int r, int rt){
    if (l == r){
        st[rt] = 0;
        ans[l] = valu;
        return ;
    }
    int m = (l + r) >> 1;
    if (pos < st[rt << 1]){          //不能等于
        Update (pos, valu, l, m, rt << 1);
    }else {
        Update (pos - st[rt << 1], valu, m + 1, r, rt << 1 | 1);
    }
    PushUp(rt);
}
int main()
{
    ios::sync_with_stdio(false);
    int N;
    while (cin >> N){
        Build(1, N, 1);
        for (int i = 1; i <= N; i++){
            cin >> pos[i] >> val[i];
        }
        for (int i = N; i > 0; i--){
            Update(pos[i], val[i], 1, N, 1);
        }
        for (int i = 1; i <= N; i++){
            cout << ans[i] <<" ";
        }
        cout << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值