I - Harmonic Number LightOJ - 1234-----------------------------数论(调和级数+欧拉常数)

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

In this problem, you are given n, you have to find Hn.

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output
For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input
12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output
Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

Sponsor

解析:

欧拉常数:e = 0.57721566490153286060651209
调和级数公式:log(n)+e+1.0/(2.0*n)

对于1e6 我们打表就可以了,后面利用调和级数公式求


#include<stdio.h>
#include<math.h>
const double e = 0.57721566490153286060651209;
const int N=1e6+100;
double a[N];
int k, n,t;
void init()
{
	for(int i=1;i<=N;i++)
	{
		a[i]=a[i-1]+1.0/(1.0*i);
	}
}
int main(){
	init();
	scanf("%d",&t);
	k=0;
	while(t--)
	{
		double ans=0;
		scanf("%d",&n);
		if(n<N) ans=a[n];
		else ans=log(n)+e+1.0/(2.0*n);
		printf("Case %d: %.10lf\n",++k,ans);
	}
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值