HDU 2647 Reward(反向拓扑,领接表,队列实现)

Reward

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15323 Accepted Submission(s): 4915

Problem Description

Dandelion’s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a’s reward should more than b’s.Dandelion’s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work’s reward will be at least 888 , because it’s a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a’s reward should be more than b’s.

Output

For every case ,print the least money dandelion ‘s uncle needs to distribute .If it’s impossible to fulfill all the works’ demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1

Author

dandelion

Source

曾是惊鸿照影来

  • 题意很明显,就是给你一个图,但是在这个题我么要反向建边,然后在拓扑排序,在这里存边用的是领接表,通过记录入过队的个数,并且判断是不是和n大小相等就可以看是否形成环了,若形成环就输出-1.
#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<climits>
#include<vector>
#include<queue>
#include<map>
#include<string>
using namespace std;
typedef long long ll;
const int maxn=100020;//题上说的是1e4的,但是提上去居然RE,索性直接开的1e5然后就直接ac,做法有点儿欠妥haaaaa.
const int maxm=200100;
const int inf=0x3f3f3f3f;
const int w=888;
int n,m,cnt=0;
int vis[maxn],dp[maxn];
int head[maxn];
struct node{
	int to;
	int next;
}edge[maxm];
void add_edge(int to,int from){//领接表加边(反向加边)
	edge[cnt].to=to;
	edge[cnt].next=head[from];
	head[from]=cnt++;
}
void toposort(){
	queue<int>q;
	int ret=0;//记录入队的个数
	for(int i=1;i<=n;i++){//先将入度为0的入队,并且把它们的值初始化为薪水w
		if(vis[i]==0){
			q.push(i);
			dp[i]=w;
			vis[i]=-1;
			ret++;
		}
	}
	while(q.size()){
		int x=q.front();
		q.pop();//使用过后直接出队
		int t=head[x];
		while(t!=-1){
			int now=edge[t].to;
			vis[now]--;//入度自减
			dp[now]=dp[x]+1;
			if(vis[now]==0){
				ret++;
				q.push(now);//再添加入度为0的入队
			}
			t=edge[t].next;
		}
	}
	if(ret!=n)
	printf("-1\n");
	else{
		int ans=0;
		for(int i=1;i<=n;i++){
			ans+=dp[i];
		}
		printf("%d\n",ans); 
	}
}
int main()
{
	while(~scanf("%d%d",&n,&m)){
		memset(head,-1,sizeof(head));
		memset(vis,0,sizeof(vis));
		for(int i=0;i<m;i++){
			int a,b;
			scanf("%d%d",&a,&b);//读入边的信息
			add_edge(a,b);
			vis[a]++;
		}
		toposort();
	}
    return 0;
}
/*
5 5
1 2
2 3
4 3
2 4
5 4
*/
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值