B - Dungeon Master POJ - 2251 (bfs三维空间)

B - Dungeon Master

 POJ - 2251 

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!
#include <iostream>
#include <string.h>
#include <queue>
using namespace std;

struct node{
    int x,y,z,step;
};

node n,m;
int a,b,c;
char s[35][35][35];
int flag[35][35][35];
int nex[6][3]= {{0,0,1},{0,0,-1},{0,1,0},{0,-1,0},{1,0,0},{-1,0,0}};

void bfs(int x,int y,int z){
    queue<node>q;
    n.x=x;
    n.y=y;
    n.z=z;
    n.step=0;
    q.push(n);
    flag[n.x][n.y][n.z]=1;
    while(!q.empty()){
        m=q.front();
        q.pop();
        if(s[m.x][m.y][m.z]=='E'){
            cout << "Escaped in " << m.step << " minute(s)." << endl;
            return ;
        }
        for(int i=0; i<6; i++){
            n.x=m.x+nex[i][0];
            n.y=m.y+nex[i][1];
            n.z=m.z+nex[i][2];
            if(n.x<1||n.x>a||n.y<1||n.y>b||n.z<1||n.z>c){
                continue;
            }
            if(s[n.x][n.y][n.z]!='#'&&flag[n.x][n.y][n.z]==0){
                flag[n.x][n.y][n.z]=1;
                n.step=m.step+1;
                q.push(n);
            }
        }
    }
    cout << "Trapped!" << endl;
}

int main()
{
    int x,y,z;
    while(cin >> a >> b >> c){
        if(a==0&&b==0&&c==0){
            break;
        }
        memset(s,0,sizeof(s));
        memset(flag,0,sizeof(flag));
        for(int i=1; i<=a; i++){
            for(int j=1; j<=b; j++){
                for(int k=1; k<=c; k++){
                    cin >> s[i][j][k];
                    if(s[i][j][k]=='S'){
                        x=i;
                        y=j;
                        z=k;
                    }
                }
            }
        }
        bfs(x,y,z);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值