PAT 1015 Reversible Primes (20分)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10^5 ) and(1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

补充:
1、如果题目没有给定的输入结束条件,那么就默认读到文件末尾,scanf读到文件末尾后无法读取后返回-1,C语言中使用EOF代表-1。

while (scanf("%d",&n) != EOF)
{
	.....
}

这道题我们也可以采用这种读取方式,先读取一个数,如果该数小于0,则break,反之,继续读入第二个数。

2、注意数据为1时,判断其不是素数,不要忽略了。

我的代码:

#include<cstdio>
bool isPrime(int num)
{
    if (num == 1) return false;
    for (int i = 2 ;i * i <= num ;i++)
    {
        if (num % i == 0)
            return false;
    }
    return true;
}
int reverse(int num,int radix)
{
    int sum = 0;
    while (num != 0)
    {
        sum = sum * radix + (num % radix);
        num /= radix;
    }
    return sum;
}
int main()
{
    int n,d;
    while (scanf("%d",&n) != EOF)
    {
        if (n < 0) break;
        scanf("%d",&d);
        if (isPrime(n))
        {
            if (isPrime(reverse(n,d)))
                printf("Yes\n");
            else
                printf("No\n");
        }
        else
            printf("No\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

情书、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值