PAT 1016 Phone Bills (25分)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:
For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

分析:
1、一道模拟排序题,难点应该在题意的理解上,计算费用上。

2、坑点:测试点1,2错误,是因为测试点会出现该用户全部为无效记录的情况,但是题目:It is guaranteed that at least one call is well paired in the input. 让人无法理解。

3、归纳:关于日期计算两日期的相距天数,计算话费(本题)等两种方法:
方法一:按起始时间一分一分的加;分钟满60变0,小时加1,小时满24变0,天数加1;到达结束日期则结束计算。

    while (c1.d < c2.d || c1.h < c2.h || c1.m < c2.m)
    {
        c1.m++;
        sum += charge[c1.h];
        if (c1.m == 60)
        {
            c1.m = 0;
            c1.h++;
        }
        if (c1.h == 24)
        {
            c1.h = 0;
            c1.d++;
        }
    }

方法二:找到个两时间点统一的对照对象,比如这道题:1:0:0分,找出两时间点和其的相对费用,算出来相减。

我的代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
int charge[24],n;//charge存取时间段的费用
struct Customer
{
    char name[25];
    int M,d,h,m,flag;//月、天、时、分、flag=0是off,=1时是on
}c;
bool cmp(const Customer &c1,const Customer &c2)
{
    if (strcmp(c1.name,c2.name) != 0)
        return strcmp(c1.name,c2.name) < 0;
    else if (c1.M != c2.M)
        return c1.M < c2.M;
    else
        return (c1.d * 24 + c1.h) * 60 + c1.m < (c2.d * 24 + c2.h) * 60 + c2.m;
}
double getcharge(Customer c1,Customer c2,int &cnt)//获取相差费用,cnt是计算相距多少时间
{
    double sum = 0;
    while (c1.d < c2.d || c1.h < c2.h || c1.m < c2.m)
    {
        c1.m++;
        cnt++;
        sum += charge[c1.h];
        if (c1.m == 60)
        {
            c1.m = 0;
            c1.h++;
        }
        if (c1.h == 24)
        {
            c1.h = 0;
            c1.d++;
        }
    }
    return sum / 100;
}
int main()
{
    vector<Customer> v;
    for (int i = 0 ;i < 24 ;i++)
        scanf("%d",&charge[i]);
    scanf("%d",&n);
    for (int i = 0 ;i < n ;i++)
    {
        char flag[10];
        scanf("%s %d:%d:%d:%d ",c.name,&c.M,&c.d,&c.h,&c.m);
        scanf("%s",flag);
        if (strcmp(flag,"on-line") == 0)
            c.flag = 1;
        else
            c.flag = 0;
        v.push_back(c);
    }
    sort(v.begin(),v.end(),cmp);
    for (int i = 0 ;i < v.size() ;i++)
    {
        double sum = 0;
        while (i + 1 < v.size() && strcmp(v[i].name,v[i+1].name) == 0)
        {
            if (v[i].flag == 1 && v[i+1].flag == 0)//电话匹配时
            {
                if (sum == 0)
                    printf("%s %02d\n",v[i].name,v[i].M);
                printf("%02d:%02d:%02d ",v[i].d,v[i].h,v[i].m);
                printf("%02d:%02d:%02d ",v[i+1].d,v[i+1].h,v[i+1].m);
                int cnt = 0;
                double pay = getcharge(v[i],v[i+1],cnt);
                printf("%d $%.2f\n",cnt,pay);
                sum += pay;
            }
            i++;        
        }
        if (sum != 0)
            printf("Total amount: $%.2f\n",sum);      
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

情书、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值