PAT 1051 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

注意:
1、栈的模拟题,直接用stl里的栈来模拟栈进栈出;用一个变量maxnum来记录进入过栈的最大数字,如果输入数字大于maxnum,则把maxnum+1到输入的数字推入到栈内,再比较栈顶数字是不是该输入数字,如果是则pop()出来;如果输入数字小于maxnum则直接比较栈顶是否等于输入的数字,如果是则pop()出来,不是就标记NO

2、如果知道是错时,不能直接break出来,因为该题目是要求不管对错都要全输入;因此设立一个标记flag最后再判断YES or NO。我就是这里没注意,直接数据全混乱,难受啊

我的代码

#include<cstdio>
#include<stack>
using namespace std;
int main()
{
    int m,n,k;
    scanf("%d%d%d",&m,&n,&k);
    for (int i = 0 ;i < k ;i++)
    {
        int j,maxnum = 0;
        stack<int> s;
        bool flag = true;
        for (j = 0 ;j < n ;j++)
        {
            int num;
            scanf("%d",&num);
            if (num - maxnum + s.size() <= m && num > maxnum)
            {
                for (int t = maxnum + 1 ;t <= num ;t++)
                    s.push(t);
                maxnum = num;
            }
            if (s.size() != 0 && s.top() == num)
                s.pop();
            else
                flag = false;
        }
        if (flag == true)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

情书、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值