PAT甲级 1013 Battle Over Cities (25 分)

5 篇文章 0 订阅
4 篇文章 0 订阅
该博客讨论了在战争情况下如何确保城市间通过高速公路保持连接的问题。通过输入城市数量、剩余道路数量和待检查城市,算法计算出如果某个城市被占领,需要修复多少条道路以保持其他城市间的连通。示例展示了对于3个城市和2条道路的情况,当城市1被占领时,需要修复1条道路。解决方案是使用深度优先搜索(DFS)算法来寻找连通块的数量。
摘要由CSDN通过智能技术生成

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1​-city2​ and city1​-city3​. Then if city1​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city2​-city3​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

结尾无空行

Sample Output:

1
0
0

结尾无空行

思路:DFS寻找连通块的个数

#include <bits/stdc++.h>
using namespace std;
const int maxv=1010;
int n,m,k,des;
vector<int> g[maxv];
bool vis[maxv];
void DFS(int v)
{
    if(v==des) return;
    vis[v]=true;
    for(int i=0;i<g[v].size();i++)
    {
        if(!vis[g[v][i]]) DFS(g[v][i]);
    }
}
int main()
{
    scanf("%d %d %d",&n,&m,&k);
    for(int i=0;i<m;i++)
    {
        int a,b;
        scanf("%d %d",&a,&b);
        g[a].push_back(b);
        g[b].push_back(a);
    }
    for(int i=0;i<k;i++)
    {
        int block=0;
        scanf("%d",&des);
        memset(vis,false,sizeof(vis));
        for(int j=1;j<=n;j++)
        {
            if(j!=des&&!vis[j])
            {
                block++;
                DFS(j);
            }
        }
        printf("%d\n",block-1);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值