Strange fuction(HDU--2899)

#题目:

Now, here is a fuction:
F(x) = 6 * x ^ 7+8x^ 6+ 7x ^ 3+5x^2-yx (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

解题思路:这个题就是给一个函数式,然后由x在区间0-100之间取值求最小值。
利用函数求导为:42*x^6+48 *x ^5+21 *x^2+10 *x-y==0,利用二分求x的值,使倒数为0,则函数值最小。

程序代码:

#include<stdio.h>
#include<math.h>
double l=0.00000001;
int main()
{
	double x,m,n,k,y,sum;
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lf",&y);
		n=0.00;
		m=100.00;//x的区间是0-100
		while(m-n>l)//让n和m无限接近,使得导函数为0
		{
			k=(m+n)/2;
			if(42*pow(k,6)+48*pow(k,5)+21*pow(k,2)+10*k-y>0)
				m=k;
			else
				n=k;
		}
		sum=6*pow(k,7)+8*pow(k,6)+7*pow(k,3)+5*pow(k,2)-y*k;
		printf("%.4f\n",sum);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

我菜就爱学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值