PAT 1038

题目

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤10^​4) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

思路和代码

  1. 这道题目的目的是给很多数字,求出他们组合起来的最小数值
  2. 因为是粘合的数字,肯定很大,所以要用string来存储
  3. 要最小,就一定要让第一位最小的数字排在前面,但是看到题目中都是3开头的数字,看起来没有什么规律
  4. 假设只有两个数字,那一定是要求a + b < b + a,所以可以类推到任意长度,因为整个排序函数调用后一定会满足这样的情况,所以排好序后一定是最小的。
#include<cstdio>
#include<string>
#include<vector>
#include<iostream>
#include<algorithm>
using namespace std;

vector<string> str;

bool cmp(string a, string b) {
	return a + b < b + a;
}

int main() {
	int n;
	string temp;
	string final;
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		cin >> temp;
		str.push_back(temp);
	}
	sort(str.begin(), str.end(), cmp);
	for (int i = 0; i < n; i++) {
		final += str[i];
	}
	while (final.size() != 0 && final[0] == '0') {
		final.erase(final.begin());
	}
	if (final.size() == 0) cout << 0;
	else cout << final;
	return 0;
}

  1. 这题目本身难度就在于找到贪心算法的解,能发现贪心的关键是保证 a + b < b + a
  2. 然后就是实现这个过程,使用sort函数即可。sort函数排好序后是一定满足排序的要求的,所以也不用太过于纠结是如何一个一个保证 a + b < b + a ,可以dubug看一下排序的过程。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值