贪心-HDU1789 Doing Homework again(活动安排问题)

题目


传送门: HDU-1789

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

input:

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

output:

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input:

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output:

0
3
5

题意

给出N个作业的截止日期和未完成的罚分,每天只能完成一个作业,求最小的罚分。

分析

首先把作业按截止日期从小到大排序,如果日期相同按罚分降序,我们希望完成尽可能多的作业。然而仅靠日期排序并不是最优的,当一项作业超过截止日期时,我们不能就简单的加上罚分,我们要把它的罚分和前面完成作业的最小罚分相比(优先队列实现),选择罚分较小的那个。

代码

#include<cstdio>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int maxn = 1003;
int t, n;
pair<int, int>p[maxn];
bool cmp(pair<int, int>a, pair<int, int>b) {
	if (a.first == b.first)
		return a.second > b.second;
	else return a.first < b.first;
}
struct cmp2 {
	bool operator()(pair<int, int>a, pair<int, int>b) {
		return a.second > b.second;

	}
};
int main() {
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		for (int i = 0; i < n; i++)
			scanf("%d", &p[i].first);
		for (int i = 0; i < n; i++)
			scanf("%d", &p[i].second);
		sort(p, p + n, cmp);//按日期升序罚分降序
		int ans = 0, day = 1;
		priority_queue<pair<int, int>,vector<pair<int, int>>, cmp2>q;
		for (int i = 0; i < n; i++)
			if (p[i].first < day) {//逾期
				if (q.top().second < p[i].second) {//和之前罚分最小的比较
					ans += q.top().second;
					q.pop();
					q.push(p[i]);
				}
				else ans += p[i].second;
			}
			else {
				q.push(p[i]);//入队
				day++;
			}
		printf("%d\n", ans);
	}
	return 0;
}

原创不易,请勿转载本不富裕的访问量雪上加霜
博主首页:https://blog.csdn.net/qq_45034708
如果文章对你有帮助,记得关注点赞收藏❤

  • 5
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

吾仄lo咚锵

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值