B - Grid Compression

B - Grid Compression

There is a grid of squares with H horizontal rows and W vertical columns. The square at the i-th row from the top and the j-th column from the left is represented as (i,j). Each square is black or white. The color of the square is given as an H-by-W matrix (ai,j). If ai,j is ., the square (i,j) is white; if ai,j is #, the square (i,j) is black.

Snuke is compressing this grid. He will do so by repeatedly performing the following operation while there is a row or column that consists only of white squares:

Operation: choose any one row or column that consists only of white squares, remove it and delete the space between the rows or columns.
It can be shown that the final state of the grid is uniquely determined regardless of what row or column is chosen in each operation. Find the final state of the grid.

Constraints
1≤H,W≤100
ai,j is . or #.
There is at least one black square in the whole grid.

Input
Input is given from Standard Input in the following format:

H W
a1,1…a1,W
:
aH,1…aH,W

Output
Print the final state of the grid in the same format as input (without the numbers of rows and columns); see the samples for clarity.

Sample Input 1
4 4
##.#

##.#
.#.#

Sample Output 1

.##
The second row and the third column in the original grid will be removed.

Sample Input 2
3 3
#…
.#.
…#

Sample Output 2
#…
.#.
…#
As there is no row or column that consists only of white squares, no operation will be performed.

Sample Input 3
4 5


…#…

Sample Output 3

Sample Input 4
7 6

…#.
.#…
…#…
…#…

.#…#.

Sample Output 4
…#
#…
.#.
.#.
#.#

代码:

#include <bits/stdc++.h>
using namespace std;
int h,w;
char room[101][101];
int book1[101],book2[101];
int main()
{
    cin>>h>>w;
    for(int i=0;i<h;i++)
        for(int j=0;j<w;j++)
            cin>>room[i][j];
    memset(book1,0,sizeof(book1));
    memset(book1,0,sizeof(book1));
    for(int i=0;i<h;i++){
        for(int j=0;j<w;j++){
            if(room[i][j]=='#'){
                book1[i]=1;
                break;
            }
        }
    }
    for(int i=0;i<w;i++){
        for(int j=0;j<h;j++){
            if(room[j][i]=='#'){
                book2[i]=1;
                break;
            }
        }
    }
    for(int i=0;i<h;i++){
            bool f=false;
        for(int j=0;j<w;j++){
            if(book1[i]==1&&book2[j]==1){
                cout<<room[i][j];
                f=true;
            }
        }
        if(f)
        cout<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值