[Loops]D. Liang 4.14 Displaying the ASCII character table.c

[Loops]D. Liang 4.14 Displaying the ASCII character table

Description

Write a program that prints the characters in the ASCII character table from ‘!’ to ‘~’ (including ‘~’).

Input

a number n (3 <= n <= 15)

Output

Print n characters per line and specify the width of each character’s print field to 2, and justify the output to right.

The characters in one line are separated by a space and there is no space at the end of the line.

Sample Input

10

Sample Output

 !  "  #  $  %  &  '  (  )  *
 +  ,  -  .  /  0  1  2  3  4
 5  6  7  8  9  :  ;  <  =  >
 ?  @  A  B  C  D  E  F  G  H
 I  J  K  L  M  N  O  P  Q  R
 S  T  U  V  W  X  Y  Z  [  \
 ]  ^  _  `  a  b  c  d  e  f
 g  h  i  j  k  l  m  n  o  p
 q  r  s  t  u  v  w  x  y  z
 {  |  }  ~
//   Date:2020/3/19
//   Author:xiezhg5
#include <stdio.h>
int main(void)
{
	int i;
	int n=0;
	int m;
	scanf("%d",&m);
	for(i=33;i<=126;i++) //查ASCII表可知范围 
	{
		printf("%2c ",i);  //将整数转换为字符串输出 
		n++;
		if(n%m==0)
			printf("\n"); //每输出n个数字后换行 
	}
	printf("\n");
	return 0;
}

Expansion: ASCII (American Standard Code for information interchange) is a set of computer coding system based on Latin alphabet, mainly used to display modern English and other Western European languages. It is the most common single byte coding system nowadays and is equivalent to the international standard ISO / IEC 646.
For more information, go to this website:
添加链接描述
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值