[Functions]D. Liang 5.13 Summing series.c

***Description
Computing series using the following formula:

m(n)=1/2+2/3++n/n+1

Input
A positive integer n (1 <= n <= 10000)
Output
Series computing by n
(The precision of series should be fixed to 4)
Sample Input

3

Sample Output

1.9167***
//   Date:2020/3/28
//   Author:xiezhg5
#include <stdio.h>
int main(void)
{
	int n;
	int i,a,b;
	float sum=0;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		a=i;
		b=a+1;
		sum=sum+1.0*a/b;
	}
	printf("%.4f\n",sum);
	return 0;
}

Only float type can be used to define sum, and double can cause the following situations:
在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值