#2020.02.04训练题解#背包入门(A题)

题源HDU-2602

HDU-2602-Bone Collector

Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

题意

  • 输入T代表有T组数据
  • 每组数据先输入一个N和V,分别代表骨头数量和袋子体积
  • 接着输入一行N个骨头的价值,以及一行N个骨头的体积
  • 求每组数据中的袋子,最多能装多少价值的骨头

题解

  • 这是01背包模板题,分别输入对应量,调用函数即可
  • 注意如果使用二维数组,第二层循环正序遍历
  • 但务必注意 从0到V,骨头的体积可以为0(题目坑点-详见代码注释部分的写法)
  • 不过 用了一维数组的空间优化后,就无需考虑这个坑点 啦٩(๑>◡<๑)۶

涉及知识点

  • 背包 算法(此题属于01背包)
  • 对于背包的算法-详见链接博客介绍背包

AC代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=1e3+10;
int T,n,v,value[maxn],cost[maxn],dp[maxn]; 
int knapsack_01()//01背包
{
	memset(dp,0,sizeof(dp));
	for(int i=1;i<=n;++i)
	{//遍历到i,就表示遍历到第i个物品,优化二维数组变为一位数组 
		for(int j=v;j>=cost[i];--j)//从大到小遍历!!!
		/*
			以防同一个物品从小到大的话
			先把小体积优化好,再优化大体积
			那么大体积用的小体积dp可能是放这个物品优化过的
			但01背包,每个物品只有一个,不可重复放 
		*/ 
		{
			if(cost[i]<=j) dp[j]=max(dp[j],dp[j-cost[i]]+value[i]);
		}
	}
	return dp[v];
/*
	二维数组code写法 
	memset(dp,0,sizeof(dp));
	for(int i=1;i<=n;++i)
	{
		for(int j=0;j<=v;++j)
		{
			if(j<c[i]) dp[i][j]=dp[i-1][j];
			else dp[i][j]=max(dp[i-1][j],dp[i-1][j-cost[i]]+value[i]);
		}
	}
	return dp[n][v];
*/
}
int main()
{
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d %d",&n,&v);
		for(int i=1;i<=n;++i) scanf("%d",&value[i]);
		for(int i=1;i<=n;++i) scanf("%d",&cost[i]);
		printf("%d\n",knapsack_01());
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值