看图写树 Undraw the Trees UVA10562

题目描述

 输入格式

输出格式

【输入样例】

2
A
|
--------
BC D
| |
----- -
E FG
#
e
|
----
f g
#

【输出样例】 

(A(B()C(E()F())D(G())))
(e(f()g()))
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cctype>
using namespace std;
const int maxn = 200 + 10;
int n;
char buf[maxn][maxn];
//递归遍历并且输出以字符buf[r][c]为根的树
void dfs(int r, int c)
{
    printf("%c(", buf[r][c]);
    if (r + 1 < n && buf[r + 1][c] == '|') //有子树
    {
        int i = c;
        while (i - 1 >= 0 && buf[r + 2][i - 1] == '-') // 找“----”的左边界
            i--;
        while (buf[r + 2][i] == '-' && buf[r + 3][i] != '\0')
        {
            if (!isspace(buf[r + 3][i])) //fgets读入的“\n”也满足isspace();
                dfs(r + 3, i);
            i++;
        }
    }
    printf(")");
}
void solve()
{
    n = 0;
    for (;;)
    {
        fgets(buf[n], maxn, stdin);
        if (buf[n][0] == '#')
            break;
        else
            n++;
    }
    printf("(");
    if (n)
    {
        for (int i = 0; i < strlen(buf[0]); i++)
            if (buf[0][i] != ' ')
            {
                dfs(0, i);
                break;
            }
    }
    printf(")\n");
}
int main()
{
    int T;
    fgets(buf[0], maxn, stdin);
    sscanf(buf[0], "%d", &T);
    while (T--)
        solve();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值