A1085 Perfect Sequence (25 分)PAT甲级(C++)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105) is the number of integers in the sequence, and p (≤109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

题意:

要求我们在输入的一系列数列中,选出一定个数的数字组成一个新的子序列(顺序无关),然后子序列要满足Max<=Min*p,p是我们输入的一个参数,在此基础上还要求该子序列的个数最多。

所以问题就简化为,先将输入的数按从小到大排序,再使用二分法一段一段查找满足条件的“Max”和“Min”,同时一边遍历一边记录每一对Max和Min之间的距离,距离最大的即序列个数最多,也就是题目要求查找的完美数列。

这样一来就很简单啦~

代码如下:

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 100010;
int n, p, a[maxn];
//在[i+1,n-1]范围内查找第一个大于x的数
int binarySearch(int i, long long x)//此时已经按从小到大的顺序排列好了
{
	if (a[n - 1] <= x)return n;//所有数都不大于x
	int l = i + 1, r = n - 1, mid;
	while (l < r) {
		mid = (l + r) / 2;
		if (a[mid] <= x) {//说明第一个大于x的数只能在右边
			l = mid + 1;
		}
		else {
			r = mid;
		}
	}
	return l;//循环结束时l==r,所以两者皆可
}
int main() {
	cin>>n>>p;
	for (int i = 0; i < n; i++)
	{
		cin>>a[i];
	}
	sort(a, a + n);
	int ans = 1;//最大长度,初值为1,表示选出的完美序列至少有一个数
	for (int i = 0; i < n; i++)
	{
		int j = binarySearch(i, (long long)a[i]*p);
		ans = max(ans, j - i);
	}
	cout<<ans;
	return 0;
}

运行结果如下:

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值