PAT甲级-1001 A+B Format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10^6 ≤a,b≤10^6. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9

Sample Output:
-999,991

题目的意思大概就是让我们输入一对整数,然后计算出他们的和,结果每隔三位加一个逗号打印输出。
解题思路:首先需要做加法并且两数最大为1000000,所以需要int型的两变量相加,相加之后要加逗号,显然int型加逗号是不方便的,我们需要把int型转成字符串,负数不方便转换先转成正数,从最低位开始走,每隔三位加一个逗号,注意最高位如果隔了三位也不能输出逗号,因为更高位没有数,所以我们只要不遍历i=0的时候最后的逗号就不会输出,这样最后再输出字符串。

#include<iostream>
#include<string>
using namespace std;

int main()
{
	int a,b,flag=0;//flag用来判断相隔几位
	cin>>a>>b;
	int sum=a+b;string ssum;
	if(sum<0) ssum=to_string(-sum);
	else ssum=to_string(sum);
	for(int i=ssum.size()-1;i>0;i--)//从字符串的最低位即size-1
	{
		flag++;
		if(flag%3==0) ssum.insert(i,",");
	}
	if(sum<0) cout<<"-"<<ssum<<endl;
	else cout<<ssum<<endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值