PAT甲级-1019 General Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a^i as ∑ i=0到k求和 (ai b^i). Here, as usual, 0≤a^i<b for all i and ak is non-zero. Then N is palindromic if and only if ai=ak−i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10^9 is the decimal number and 2≤b≤10^9
is the base. The numbers are separated by a space.

Output Specification:
For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form “ak ak−1… a0”. Notice that there must be no extra space at the end of output.

Sample Input 1:
27 2

Sample Output 1:
Yes
1 1 0 1 1

Sample Input 2:
121 5

Sample Output 2:
No
4 4 1

题目大概意思是判断第一个整数在该进制下的数是不是回文。
解题思路:我们先要注意一个点就是进制的范围,进制不再是10以内的,所以可能会出现某位上是多位数的情况,这样我们就要把每一位的数分开存储才能比较前面的位和后面的位是否相同。

#include<iostream>
#include<vector>
using namespace std;

int main()
{
	int N,b,i;
	vector<int> digit;
	cin>>N>>b;
	while(N>0) {
		digit.push_back(N%b);
		N/=b;
	}
	for(i=0;i<digit.size()/2;i++)
		if(digit[i]!=digit[digit.size()-i-1]) break;
	if(i==(digit[i].size()/2)) cout<<"Yes"<<endl;
	else cout<<"No"<<endl;
	for(i=digit.size()-1;i>=0;i--)
	{
		cout<<digit[i];
		if(i>0) cout<<" ";
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值