PAT (Basic Level) Practice (中文)1086 就不告诉你 (15 分)
做作业的时候,邻座的小盆友问你:“五乘以七等于多少?”你应该不失礼貌地围笑着告诉他:“五十三。”本题就要求你,对任何一对给定的正整数,倒着输出它们的乘积。
输入格式
输入在第一行给出两个不超过 1000 的正整数 A 和 B,其间以空格分隔。
输出格式
在一行中倒着输出 A 和 B 的乘积。
输入样例
5 7
输出样例
53
思路
- 计算结果之后转为字符串
reverse
- 输出的时候不要输出前导零
AC code
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
int main(){
int a,b;
cin>>a>>b;
string s=to_string(a*b);
reverse(s.begin(),s.end());
bool flag=true; //是不是前导零
for(auto& x:s){
if(x=='0' and flag) continue;
else if(x!='0'){
cout<<x;
flag = false;
}
else{
cout<<x;
}
}
return 0;
}