PTA 列出叶结点 (10 分)

对于给定的二叉树,本题要求你按从上到下、从左到右的顺序输出其所有叶节点。

输入格式:

  • 首先第一行给出一个正整数 N(≤10),为树中结点总数。树中的结点从 0N−1 编号。随后 N 行,每行给出一个对应结点左右孩子的编号。如果某个孩子不存在,则在对应位置给出 "-"。编号间以 1 个空格分隔。

输出格式:

  • 在一行中按规定顺序输出叶节点的编号。编号间以 1 个空格分隔,行首尾不得有多余空格。

输入样例:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
结尾无空行

输出样例:

4 1 5
结尾无空行

AC:

#include <bits/stdc++.h>
using namespace std;
typedef struct BiTNode
{
    int rchild;
    int lchild;
} Tree;
Tree tree[100];
int flag[100];
int findRoot(int n);
void level(int root);
int main()
{
    std::ios_base::sync_with_stdio(false);
    int n;
    cin >> n;
    for (int i = 0; i < n; i++)
    {
        char lchild, rchild;
        getchar();
        cin >> lchild >> rchild;
        if (lchild == '-')
        {
            tree[i].lchild = -1;
        }
        else
        {
            tree[i].lchild = lchild - '0';
            flag[lchild - '0'] = 1;
        }
        if (rchild == '-')
        {
            tree[i].rchild = -1;
        }
        else
        {
            tree[i].rchild = rchild - '0';
            flag[rchild - '0'] = 1;
        }
    }
    int root = findRoot(n);
    if (n > 0)
    {
        level(root);
    }
    return 0;
}
int findRoot(int n)
{
    int i = 0;
    while(flag[i] != 0 && i < n) 
        i++;
    return i;
}
void level(int root)
{
    int count = 0;
    int queue[20];
    int front = 0;
    int rear = 0;
    queue[rear++] = root;
    while (rear != front)
    {
        int now = queue[front++];
        if (tree[now].lchild == -1 && tree[now].rchild == -1)
        {
            if (count == 0)
            {
                cout << now;
                count = 1;
            }
            else
            {
                cout << " " << now;
                count = 1;
            }
        }
        if (tree[now].lchild != -1)
        {
            queue[rear++] = tree[now].lchild;
        }
        if (tree[now].rchild != -1)
        {
            queue[rear++] = tree[now].rchild;
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值