对于给定的二叉树,本题要求你按从上到下、从左到右的顺序输出其所有叶节点。
输入格式:
- 首先第一行给出一个正整数
N(≤10)
,为树中结点总数。树中的结点从0
到N−1
编号。随后N
行,每行给出一个对应结点左右孩子的编号。如果某个孩子不存在,则在对应位置给出"-"
。编号间以1
个空格分隔。
输出格式:
- 在一行中按规定顺序输出叶节点的编号。编号间以
1
个空格分隔,行首尾不得有多余空格。
输入样例:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
结尾无空行
输出样例:
4 1 5
结尾无空行
AC:
#include <bits/stdc++.h>
using namespace std;
typedef struct BiTNode
{
int rchild;
int lchild;
} Tree;
Tree tree[100];
int flag[100];
int findRoot(int n);
void level(int root);
int main()
{
std::ios_base::sync_with_stdio(false);
int n;
cin >> n;
for (int i = 0; i < n; i++)
{
char lchild, rchild;
getchar();
cin >> lchild >> rchild;
if (lchild == '-')
{
tree[i].lchild = -1;
}
else
{
tree[i].lchild = lchild - '0';
flag[lchild - '0'] = 1;
}
if (rchild == '-')
{
tree[i].rchild = -1;
}
else
{
tree[i].rchild = rchild - '0';
flag[rchild - '0'] = 1;
}
}
int root = findRoot(n);
if (n > 0)
{
level(root);
}
return 0;
}
int findRoot(int n)
{
int i = 0;
while(flag[i] != 0 && i < n)
i++;
return i;
}
void level(int root)
{
int count = 0;
int queue[20];
int front = 0;
int rear = 0;
queue[rear++] = root;
while (rear != front)
{
int now = queue[front++];
if (tree[now].lchild == -1 && tree[now].rchild == -1)
{
if (count == 0)
{
cout << now;
count = 1;
}
else
{
cout << " " << now;
count = 1;
}
}
if (tree[now].lchild != -1)
{
queue[rear++] = tree[now].lchild;
}
if (tree[now].rchild != -1)
{
queue[rear++] = tree[now].rchild;
}
}
}