每日一题之2074. 倒计数

要求

 

输入样例:

3
12 3
1 2 3 7 9 3 2 1 8 3 2 1
4 2
101 100 99 98
9 6
100 7 6 5 4 3 2 1 100

输出样例:

Case #1: 2
Case #2: 0
Case #3: 1

样例解释

0726自写代码

#include<iostream>
#include<cstring>
#include<algorithm>
//暴力 
using namespace std;
const int N=200010;
int A[N];
int t=1;
int main()
{
	int T,n,K,ans;
	cin>>T;
	int i,j;
	int x;
	while(T--){
	cin>>n>>K;
	for(i=0;i<n;i++)
		cin>>A[i]; 
	ans=0;
	for(i=0;i<n;i++){
		if(A[i]==K)
			for(j=i+1;j<n;j++){
				if(A[j]!=A[j-1]-1)
				break;
				if(A[j]==1)
				{
					ans++;
					break;
				}
			}
	}cout<<"Case #"<<t++<<":"<<ans<<endl;
	}
	
	return 0;
}

tips:

输入规模>=10^5用scanf() 

法二:双指针(有点问题)

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

const int N=200010;
int n,m;
int A[N];
int t=1;
int main() {
	int T,n,K,ans;
	scanf("%d",&T);
	int x;
	while(T--) {
		cin>>n>>K;
		for(int i=0; i<n; i++)
			scanf("%d",&A[i]);
	ans=0;
	//双指针

		for(int r=n;r;r--){
			if(A[r]!=1)
			continue;
			int j=r-1;
			while(j&&A[j]==A[j+1]+1)
			j--;
			if(r-j>=K)
			ans++;
			r=j+1;
		}
			cout<<"Case #"<<t++<<":"<<ans<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值