1010 Radix

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1​ and N2​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:


N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible
#include<iostream>
#include<algorithm>
#include<cctype>
#include<cmath>
using namespace std;
long long convert(string s, long long radix){//把s转换成10进制
    int index = 0, temp = 0;
    long long sum = 0;
    for (auto it = s.rbegin(); it != s.rend(); it++){
        temp = isdigit(*it) ? *it - '0' : *it - 'a' + 10;
        sum += temp * pow(radix, index++);
    }
    return sum;
}
long long final_result(string s, long long num){//寻找在什么进制下两数相等
    char it = *max_element(s.begin(), s.end());
    long long low = (isdigit(it) ? it - '0' : it - 'a' + 10 ) + 1;
    long long high = max(num, low);
    while(low <= high){
        long long mid = low + (high - low) / 2;
        long long temp = convert(s, mid);
        if ( temp== num)
            return mid;
        else if (temp > num || temp < 0)
            high = mid - 1;
        else
            low = mid + 1;
    }
    return -1;
}
int main(){
    string str1, str2;
    int tag;
    long long radix;
    cin >> str1 >> str2 >> tag >> radix;
    long long result = (tag == 1 ? final_result(str2, convert(str1, radix)) : final_result(str1, convert(str2, radix)));
    if (result != -1) {
        cout << result << endl;
    }
    else {
        cout << "Impossible" << endl;
    }
    return 0;
}

本题思路:首先将已知进制的那个数转化为十进制数,然后二分查找区间(进制的范围)是: 最小区间为 未知进制的数的数位最大值加一, 最大区间为转化的十进制数和最小区间的最大值(有可能该十进制数很小)。然后进行二分查找。对于一个确定的数字串来说,他的进制越大,该数字转化为十进制的结果也就越大。

补充: 

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值