Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N
(≤104, the total number of coins) and M
(≤102, the amount of money Eva has to pay). The second line contains N
face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the face values V1≤V2≤⋯≤Vk such that V1+V2+⋯+Vk=M
. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.
Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].
Sample Input 1:
8 9
5 9 8 7 2 3 4 1
Sample Output 1:
1 3 5
Sample Input 2:
4 8
7 2 4 3
Sample Output 2:
No Solution
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 10010;
const int maxV = 110;
int w[maxn], dp[maxn];
bool choice[maxn][maxn], flag[maxn];
bool cmp(int a, int b){
return a > b;
}
int main(){
int n, m;
cin >> n >> m;
for (int i = 1; i <= n; i++)
cin >> w[i];
sort(w + 1, w + n + 1, cmp);
for (int i = 1; i <= n; i++) {
for (int j = m; j >= w[i]; j--) {
if (dp[j] <= dp[j - w[i]] + w[i]) {
dp[j] = dp[j - w[i]] + w[i];
choice[i][j] = 1;
}
else
{
choice[i][j] = 0;
}
}
}
if (dp[m] != m) {
cout << "No Solution" << endl;
return 0;
}
int k = n, num = 0, v = m;
while (k >= 0) {
if (choice[k][v] == 1) {
flag[k] = true;
num++;
v-=w[k];
}
else
flag[k] = false;
k--;
}
for (int i = n; i >= 1; i--) {
if (flag[i] == true) {
cout << w[i];
num--;
if (num > 0)
cout << " ";
}
}
return 0;
}
本题思路:该题可以转化为01背包问题,价值和重量是等价的,因此均用w数组来存放。由于题目要求输出方案,所以用二维数组choice【i】【v】=0表示 遍历到第i件物品时不选,choic【i】【v】等于1表示遍历到第i件物品时选择。
当求解dp数组完毕后,从第n件物品开始倒着查看每一件物品是否放入背包,如果放入背包,则标记对应的flag为true,否则为false,同时记录选择物品的个数(用于最后控制输出空格)。