1027 Colors in Mars

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456
#include<iostream>
using namespace std;
int main(){
    string str = "0123456789ABC";
    int a, b, c;
    cin >> a >> b >> c;
    cout << "#" << str[(a / 13)] << str[(a % 13)]
    << str[(b / 13)] << str[(b % 13)]
    << str[(c / 13)] << str[(c % 13)]<<endl;
    return 0;
}

因为题目给定的是0-168,小于13的平方169,所以转为13进制最多有两位。 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
Matplotlib provides a wide range of colors that can be used in plots and visualizations. Here are a few ways to specify colors in Matplotlib: 1. Specifying the color by name: Matplotlib supports named colors such as 'blue', 'red', 'green', etc. You can use these names directly when setting the color of an element. For example: ```python import matplotlib.pyplot as plt plt.plot(x, y, color='red') ``` 2. Specifying the color using RGB values: You can also specify a color using RGB values by passing a tuple or a list containing three values between 0 and 1 representing the red, green, and blue channels, respectively. For example: ```python import matplotlib.pyplot as plt plt.plot(x, y, color=(0.2, 0.4, 0.6)) ``` 3. Specifying the color using hexadecimal notation: Another way to specify colors is by using hexadecimal notation. The hexadecimal value starts with a pound sign (#) followed by six digits representing the red, green, and blue channels. For example: ```python import matplotlib.pyplot as plt plt.plot(x, y, color='#FF0000') # This represents red ``` 4. Using colormap: Matplotlib provides various colormaps that can be used to create a range of colors. Colormaps can be useful for visualizing scalar data or creating color palettes. You can use colormaps by passing their name to the `cmap` parameter. For example: ```python import matplotlib.pyplot as plt plt.scatter(x, y, c=z, cmap='viridis') ``` These are some of the ways to specify colors in Matplotlib. You can explore more options and customization by referring to the Matplotlib documentation.
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值