1045 Favorite Color Stripe

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤104) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxc = 210;
const int maxn = 10010;
int hashTable[maxc];
int a[maxn], dp[maxn];
int main(){
    int n, m, x;
    cin >> n >> m;
    memset(hashTable, -1, sizeof(hashTable));
    for (int i = 0; i < m; i++) {
        cin >> x;
        hashTable[x] = i;
    }
    int l, num = 0;
    cin >> l;
    for (int i = 0; i < l; i++) {
        cin >> x;
        if (hashTable[x] >= 0) {
            a[num++] = hashTable[x];
        }
    }
    int ans = -1;
    for (int i = 0; i < num; i++) {
        dp[i] = 1;
        for (int j = 0; j < i; j++) {
            if (a[i] >= a[j] && dp[j] + 1 > dp[i])
                dp[i] = dp[j] + 1;
        }
        ans = max(ans, dp[i]);
    }
    cout << ans << endl;
    return 0;
}

本题思路:

1.  采用最长不下降子序列模板来做:由于最长不下降子序列问题中寻找的子序列是一个非递减序列,所以将eva喜欢的颜色映射到一个递增序列中,{2,3, 1, 5, 6} 映射为{0,1,2,3,4}然后再套用模板来求长度。

2.  采用最长不下降子序列模板来做:由于本题允许公共序列产生重复元素,例如“ABBC”与“AABC”的最长公共子序列为“AABBC”,所以要对原模型进行修改。

当a【i】和b【j】不相等时,由于可以产生重复元素,dp【i】【j】可以被dp【i-1】【j】和dp【i】【j-1】影响,例如在字符串“AA”和“AB”中,dp【2】【2】可以由dp【2】【1】得到(“AA”和“A”),而字符串“AB”和“AA”中,dp【2】【2】可以由dp【1】【2】得到(“A”和“AA”),所以当a【i】和b【j】不相等时dp【i】【j】取dp【i-1】【j】和dp【i】【j-1】中的较大值,而a【i】和b【j】相等时,dp【i】【j】是dp【i-1】【j】和dp【i】【j-1】中的较大值+1.

//原模型            
            if(a[i]==b[j])
				dp[i][j]=dp[i-1][j -1]+1;
			else
				dp[i][j]=max(dp[i-1][j],dp[i][j-1]);

 

//现模型            
            if(a[i]==b[j])
				dp[i][j]=max(dp[i-1][j],dp[i][j-1])+1;
			else
				dp[i][j]=max(dp[i-1][j],dp[i][j-1]);

 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[210][10010],a[210],b[10010];
 
int main()
{
	int n,m,t,L;
	scanf("%d %d",&n,&m);
	for(int i=1;i<=m;++i)
	{
		scanf("%d",&a[i]);
		dp[i][0]=0;
	}
	scanf("%d",&L);
	for(int i=1;i<=L;++i)
	{
		scanf("%d",&b[i]);
		dp[0][i]=0;
	}
	dp[0][0]=0;
	for(int i=1;i<=m;++i)
	{
		for(int j=1;j<=L;++j)
		{
			if(a[i]==b[j])
				dp[i][j]=max(dp[i-1][j],dp[i][j-1])+1;
			else
				dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
		}
	}
	printf("%d\n",dp[m][L]);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值