【问题描述】定义了一个以hours, minutes和seconds作为数据成员的Time类。设计了成员函数将两个Time对象相加(即时间相加),并进行相应的检查,查看增加的分钟数及秒数是否大于59。如果秒数大于59,则分钟数向前递增1。类似地,如果分钟数大于59,则小时数向前增1。
【输入形式】输入两个由时、分、秒构成的时间。
【输出形式】输出输入的两个时间相加后的时间
【样例输入】
2 34 45
1 47 56
【样例输出】
the result is:4:22:41
【样例输入】
2 67 100
1 56 200
【样例输出】
the result is:5:8:0
【样例说明】
【评分标准】
代码如下:
#include<iostream>
using namespace std;
class Time
{
private:
int hours, minutes, seconds;
public:
void setTime(int h, int m, int s) {
hours = h;
minutes = m;
seconds = s;
}
void addTime(Time t1, Time t2) {
seconds = t1.seconds + t2.seconds;
minutes = t1.minutes + t2.minutes + seconds / 60;
hours = t1.hours + t2.hours + minutes / 60;
seconds %= 60;
minutes %= 60;
}
void showTime() {
cout << hours << ":" << minutes << ":" << seconds << endl;
}
};
int main()
{
int h1, m1, s1, h2, m2, s2;
cin >> h1 >> m1 >> s1 >> h2 >> m2 >> s2;
Time t1, t2, t3;
t1.setTime(h1, m1, s1);
t2.setTime(h2, m2, s2);
t3.addTime(t1, t2);
cout << "the result is:";
t3.showTime();
return 0;
}