TZOJ:5103: Electric Fence

题目:

In this problem, "lattice points" in the plane are points with integer coordinates.

In order to contain his cows, Farmer John constructs a triangular electric fence by stringing a "hot" wire from the origin (0,0) to a lattice point [n,m] (0<=n<32,000, 0<m<32,000), then to a lattice point on the positive x axis [p,0] (0<p<32,000), and then back to the origin (0,0).

A cow can be placed at each lattice point within the fence without touching the fence (very thin cows). Cows can not be placed on lattice points that the fence touches. How many cows can a given fence hold?

输入:

The single input line contains three space-separated integers that denote n, m, and p.

输出:

A single line with a single integer that represents the number of cows the specified fence can hold.

样例输入:

7 5 10

样例输出:

20

思路:

皮克定:面积S和内部格点数目a、边上格点数目b的关系:S = a + b/2 - 1。

边上格点:一条直线((0,0),(n,m))上的格点数等于n与m的最大公约数+1。

#include<bits/stdc++.h>
using namespace std;
const int inf=0x3f3f3f3f;
typedef pair<int,int> pii;
typedef long long ll;
const ll MOD=1000000007;
const int N=1e6+10;

int n,m,p,b;
double s; 
int gcd(int a,int b){
	if(b==0) return a;
	return gcd(b,a%b);
}
void solve(){
	cin>>m>>n>>p;//2s=2a+b-2
	s=1.0*p*n/2;
	b=p+gcd(n,m)+gcd(abs(p-m),n);
	cout<<(int)(s+1-b/2);
}
int main(){
	ios::sync_with_stdio(0),cin.tie(0);
	int t=1;
	//cin>>t;
	while(t--){
		solve();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值