(Java)1031 Hello World for U

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

给定任意一个N(≥5)个字符的字符串,要求将这些字符形成U的形状。例如,helloworld可以打印为: 

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1​ characters, then left to right along the bottom line with n2​ characters, and finally bottom-up along the vertical line with n3​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1​=n3​=max { k | k≤n2​ for all 3≤n2​≤N } with n1​+n2​+n3​−2=N.

也就是说,字符必须按原始顺序打印,从n1的左竖线自上而下开始​字符,然后沿着带有n2的底线从左到右​字符,最后沿垂直线自下而上使用n3​字符。而且,我们希望U是尽可能平方的——也就是说,它必须满足n1​=n3​=最大{k|k≤n2​对于所有3≤n2​≤N}与n1​+n2​+n3​−2=N。 

 

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

每个输入文件包含一个测试用例。每个大小写包含一个字符串,一行中不少于5个字符,不超过80个字符。字符串不包含空白。 

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

对于每个测试用例,按照描述中指定的U形打印输入字符串。 

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

思路:首先我们确定一下n1 n2 n3的值,题目中已经给了怎么样去推,我们直接暴力搜索确定值

               然后创建一个行为n1,列为n2的字符数组,输出

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays;

class Main{
    public static void main(String[] args) throws IOException {
        BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
        String s = bf.readLine();
        int N = s.length();
        int n1 = 0 ,n3 = 0;
        int n2;
        int max = 0;
        for( n2 = 3 ; n2 <= N ; n2 ++)
        {
            for(int k = n2 ; k >= 0 ; k--)
            {
                if(2*k + n2 - 2 == N)
                {
                    if(k > max)
                    {
                        max = k;
                        n1 =  max;
                        n3 = max;
                    }
                }
            }
        }
        n2 = N + 2 - n1 - n3;
        char [][]res = new char[n1][n2];
        for(char []c : res)
        {
            Arrays.fill(c,' ');
        }
        int index = 0;
        for(int i = 0 ; i < n1 ;i++)
        {
            res[i][0] = s.charAt(index++);
        }
        for(int j = 1 ; j < n2 ;j++)
        {
            res[n1 - 1][j] = s.charAt(index++);
        }
        for(int i = n3 - 2 ; i >= 0 ;i--)
        {
            res[i][n2 - 1] = s.charAt(index++);
        }
        for(int i = 0 ; i < n1 ;i++)
        {
            for(int j = 0 ; j < n2 ;j++)
            {
                System.out.print(res[i][j]);
            }
            System.out.println();
        }
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值