[math][第二阶段-easy math][HDU-2138]How many prime numbers

81 篇文章 0 订阅
35 篇文章 0 订阅
Problem Description
  Give you a lot of positive integers, just to find out how many prime numbers there are.
 


Input
  There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 


Output
  For each case, print the number of prime numbers you have found out.
 


Sample Input
  
  
3 2 3 4
 


Sample Output
  
  
2
 


import java.util.Scanner;


public class Main {
	public static boolean judge(int n){
		int i;
		if(n==2)return true;
		for(i=2;i<Math.sqrt(n)+1;i++){
			if(n%i==0)
				return false;
		}
		return true;
	}
	
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		
		while(in.hasNext()){
		int n = in.nextInt();
		int i,sum=0;
		for(i=0;i<n;i++){
			int m = in.nextInt();
			if(judge(m))sum++;
		}
		System.out.println(sum);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值