【PAT】1046.Shortest Distance (20)

题目:http://pat.zju.edu.cn/contests/pat-101-102-3-2012-12-16/A

题目描述:

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7


分析:题目描述的场景可以形成一个环,考虑在一个环上点A到点B可以有两个不同方向,取这两个方向较小者。

代码:http://blog.csdn.net/sunbaigui/article/details/8657186



#include<iostream>
#include<cmath>
using namespace std;
#define MAX 100000
int dis[MAX];

int min(int a,int b){
	if(a>b) return b;
	else
		return a;
}

int main()
{
	int N,M;
	int total = 0; //如果变量没有初始化便进行运算,会出错。
	int i,j,temp;
	int begin,end;
	cin>>N;
	dis[1] = 0;
	for(i=1; i<=N; i++){
		cin>>temp;
		total += temp;
		dis[i+1] = dis[i] + temp;
	}

	cin>>M;
	while(M--){
		cin>>begin>>end;

		temp = abs(dis[end] - dis[begin]);
		cout<<min( temp,total-temp )<<endl;		
	}

	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值