Largest Rectangle in a Histogram 单调栈

 Largest Rectangle in a Histogram

时间限制: 1 Sec  内存限制: 128 MB
提交: 12  解决: 6
[提交] [状态] [讨论版] [命题人:admin]

题目描述

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

 

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input

 

输入

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

 

输出

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

 

 

样例输入

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

 

样例输出

8
4000

 

提示

Huge input, scanf is recommended.

贴一个大佬博客,讲的很清晰,初学一直不清楚出栈的高度所代表的矩形面积怎么计算,全靠这个博客

https://blog.csdn.net/xiangaccepted/article/details/80019376

简单来说就是维护一个单调递增的栈

当入栈元素小于栈顶元素时,弹出该元素,并用一个数组记录该高度能延伸的最长距离,即矩形的宽度,更新结果求最大值

代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxx=1e5+10;
ll a[maxx];
ll sta[maxx],num[maxx];
int main()
{
    int n;
    while(cin>>n){
        if(n==0)  break;
        for(int i=1; i<=n; i++)
            cin>>a[i];
        a[++n]=0;
        int l=1,r=0;
        ll ans=0;
        for(int i=1; i<=n; i++){
            ll temp=0;
            while(l<=r && a[i]<=a[sta[r]]){
                temp+=num[r];
                ans=max(ans,a[sta[r]]*temp);
                r--;
            }
            sta[++r]=i;
            num[r]=temp+1;
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值