【POJ 2559】Largest Rectangle in a Histogram(单调栈)

14 篇文章 0 订阅
2 篇文章 0 订阅

Largest Rectangle in a Histogram
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18269 Accepted: 5872
Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,…,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output

8
4000
Hint

Huge input, scanf is recommended.
Source

Ulm Local 2003

【题解】【单调栈的应用,其实也是很裸的单调栈……】
【由于本题是求最大矩形面积,实际上和 2796 很像,也是求一个较长的区间并且乘上这个区间的最小值后最大,单调栈来处理】

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
using namespace std;
struct find{
    ll l,r;
}f[200010];
ll d[200010],n,maxn,stack[200010],tot;
inline void init(ll x)
{
 if(x==1) {stack[++tot]=x; return;}
 while(d[stack[tot]]>=d[x]&&tot)
  {
   f[x].l=f[stack[tot]].l;
   f[stack[tot-1]].r=f[stack[tot]].r;
   tot--;
  }
 f[stack[tot]].r=f[x].r;
 stack[++tot]=x;
 return;
}
inline void pop()
{
    f[stack[tot-1]].r=f[stack[tot]].r;
    tot--;
}
int main()
{
 ll i;
 while(scanf("%lld",&n)==1&&n)
  {
    memset(d,0,sizeof(d));
    tot=0;
    for(i=1;i<=n;++i)
     {
      scanf("%lld",&d[i]);
      f[i].l=f[i].r=i;
     }
   for (i=1;i<=n;++i) init(i);
   while(tot) pop();
   for (i=1;i<=n;++i)
    {
     ll s1=f[i].r-f[i].l+1;
     if (s1*d[i]>=maxn)
     maxn=s1*d[i];
    }
   printf("%lld\n",maxn);
   maxn=0;
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值