FZU2271 X(最短路,Folyd变形)(第七届福建省大学生程序设计竞赛)

题目:

 Problem 2271 X

Accept: 28    Submit: 115
Time Limit: 1500 mSec    Memory Limit : 32768 KB

 Problem Description

X is a fully prosperous country, especially known for its complicated transportation networks. But recently, for the sake of better controlling by the government, the president Fat Brother thinks it’s time to close some roads in order to make the transportation system more effective.

Country X has N cities, the cities are connected by some undirected roads and it’s possible to travel from one city to any other city by these roads. Now the president Fat Brother wants to know that how many roads can be closed at most such that the distance between any two cities in country X does not change. Note that the distance between city A and city B is the minimum total length of the roads you need to travel from A to B.

 Input

The first line of the date is an integer T (1 <= T <= 50), which is the number of the text cases.

Then T cases follow, each case starts with two numbers N, M (1 <= N <= 100, 1 <= M <= 40000) which describe the number of the cities and the number of the roads in country X. Each case goes with M lines, each line consists of three integers x, y, s (1 <= x, y <= N, 1 <= s <= 10, x is not equal to y), which means that there is a road between city x and city y and the length of it is s. Note that there may be more than one roads between two cities.

 Output

For each case, output the case number first, then output the number of the roads that could be closed. This number should be as large as possible.

See the sample input and output for more details.

 Sample Input

22 31 2 11 2 11 2 23 31 2 12 3 11 3 1

 Sample Output

Case 1: 2Case 2: 0

 Source

第七届福建省大学生程序设计竞赛-重现赛(感谢承办方闽江学院)

思路:

给一个无向图,然后每两个点之间有最短路,题目要求是删除一些多余的边,使得删除以后每两点之间的最短路长度不变

我们先用Folyd求出多源最短路,在求之前把原来的图拷贝一份并且把多余的边提前记录一下,然后遍历一下所有点,如果

1. 两点之间的最短路距离小于原来的最短路距离,就证明这一点发生了更新,这一条边就可以删

2. 两点之间的距离通过一个中转点可以发生更新,那么这一条边就可以删

注意一下重复的问题


代码:

#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <iostream>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <algorithm>
#define  mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define mod 10000007
#define debug() puts("what the fuck!!!")
#define N 150
#define ll long long
using namespace std;
int map[N][N], b[N][N];
int n,m;
int main()
{
	int t,x,y,z,q=1;
	scanf("%d",&t);
	while(t--)
	{
		int cnt=0;
		mem(map,0);
		scanf("%d%d",&n,&m);
		for(int i=1; i<=n; i++)
			for(int j=1; j<=n; j++)
				map[i][j]=(i==j)?0:inf;
		for(int i=1; i<=m; i++)
		{
			scanf("%d%d%d",&x,&y,&z);
			if(map[x][y]!=inf)
				cnt++;
			if(map[x][y]>z)
				map[x][y]=map[y][x]=z;
		}
		memcpy(b,map,sizeof(b));
		for(int k=1; k<=n; k++)
			for(int i=1; i<=n; i++)
				for(int j=1; j<=n; j++)
					if(map[i][k]+map[k][j]<map[i][j])
						map[i][j]=map[i][k]+map[k][j];
		for(int i=1; i<=n; i++)
			for(int j=i+1; j<=n; j++)
				for(int k=1; k<=n; k++)
				{
					if(map[i][j]<b[i][j]&&b[i][j]!=inf&&i!=j&&k!=j&&i!=k)
					{
						cnt++;
						break;
					}
					if(map[i][j]==map[i][k]+map[k][j]&&b[i][j]!=inf&&i!=j&&k!=j&&i!=k)
					{
						cnt++;
						break;
					}
				}
		printf("Case %d: %d\n",q++,cnt);
	}
	return 0;
}


































  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值