04-树7 二叉搜索树的操作集

本题要求实现给定二叉搜索树的5种常用操作。

  • 函数Insert将X插入二叉搜索树BST并返回结果树的根结点指针;
  • 函数Delete将X从二叉搜索树BST中删除,并返回结果树的根结点指针;如果X不在树中,则打印一行Not Found并返回原树的根结点指针;
  • 函数Find在二叉搜索树BST中找到X,返回该结点的指针;如果找不到则返回空指针;
  • 函数FindMin返回二叉搜索树BST中最小元结点的指针;
  • 函数FindMax返回二叉搜索树BST中最大元结点的指针。
    输入样例:
10
5 8 6 2 4 1 0 10 9 7
5
6 3 10 0 5
5
5 7 0 10 3

输出样例:

Preorder: 5 2 1 0 4 8 6 7 10 9
6 is found
3 is not found
10 is found
10 is the largest key
0 is found
0 is the smallest key
5 is found
Not Found
Inorder: 1 2 4 6 8 9
#include <stdio.h>
#include <stdlib.h>

typedef int ElementType;
typedef struct TNode *Position;
typedef Position BinTree;
struct TNode
{
    ElementType Data;
    BinTree Left;
    BinTree Right;
};

void PreorderTraversal( BinTree BT ); 
void InorderTraversal( BinTree BT );  
BinTree Insert( BinTree BST, ElementType X );
BinTree Delete( BinTree BST, ElementType X );
Position Find( BinTree BST, ElementType X );
Position FindMin( BinTree BST );
Position FindMax( BinTree BST );

int main()
{
    BinTree BST, MinP, MaxP, Tmp;
    ElementType X;
    int N, i;

    BST = NULL;
    scanf("%d", &N);
    for ( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Insert(BST, X);
    }
    printf("Preorder:"); PreorderTraversal(BST); printf("\n");
    MinP = FindMin(BST);
    MaxP = FindMax(BST);
    scanf("%d", &N);
    for( i=0; i<N; i++ ) 
	{
        scanf("%d", &X);
        Tmp = Find(BST, X);
        if (Tmp == NULL) printf("%d is not found\n", X);
        else 
		{
            printf("%d is found\n", Tmp->Data);
            if (Tmp==MinP) printf("%d is the smallest key\n", Tmp->Data);
            if (Tmp==MaxP) printf("%d is the largest key\n", Tmp->Data);
        }
    }
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Delete(BST, X);
    }
    printf("Inorder:"); InorderTraversal(BST); printf("\n");

    return 0;
}

void PreorderTraversal( BinTree BT )
{
	if(BT)
	{
		printf("%d ", BT->Data);
		PreorderTraversal( BT->Left );
		PreorderTraversal( BT->Right );
	}
} 

void InorderTraversal( BinTree BT )
{
	if(BT)
	{
		InorderTraversal( BT->Left );
		printf("%d ", BT->Data);
		InorderTraversal( BT->Right );
	}
} 

BinTree Insert( BinTree BST, ElementType X )
{
	if( !BST )
	{   /*若原树为空,生成并返回一个结点的二叉搜索树*/         
	  	BST = malloc(sizeof(struct TNode));         
		BST->Data = X;         
		BST->Left = BST->Right = NULL;     
	}
	else  /*开始找要插入元素的位置*/
	{
		if( X < BST->Data ) BST->Left = Insert( BST->Left, X ); /*递归插入左子树*/         
		else  if( X > BST->Data ) BST->Right = Insert( BST->Right, X); /*递归插入右子树*/
		/* else X已经存在,什么都不做 */         			
	}  
	return BST;        		
}

BinTree Delete( BinTree BST, ElementType X )
{
	Position Tmp;      
	if( !BST ) printf("Not Found\n");      
	else if( X < BST->Data ) BST->Left = Delete( BST->Left, X ); /* 左子树递归删除 */     
	else if( X > BST->Data ) BST->Right = Delete( BST->Right, X ); /* 右子树递归删除 */     
	else /*找到要删除的结点 */ 
	{
		if( BST->Left && BST->Right ) 
		{ /*被删除结点有左右两个子结点 */               
			Tmp = FindMin( BST->Right );/*在右子树中找最小的元素填充删除结点*/              
			BST->Data = Tmp->Data;               
			BST->Right = Delete( BST->Right, BST->Data );/*在删除结点的右子树中删除最小元素*/          
		} 
		else 
		{ /*被删除结点有一个或无子结点*/              
			Tmp = BST;               
			if( !BST->Left ) /* 有右孩子或无子结点*/                   
				BST = BST->Right;               
			else if( !BST->Right ) /*有左孩子或无子结点*/ 
				BST = BST->Left;              
			free( Tmp );          
		}
	}          
	return BST; 
}

Position Find( BinTree BST, ElementType X )
{
	if( !BST ) return NULL; /*查找失败*/ 
	if( X > BST->Data )  
    	return Find( BST->Right, X ); /*在右子树中继续查找*/ 
	else if( X < BST->Data )  
    	return Find( BST->Left, X ); /*在左子树中继续查找*/ 
	else 
    	return BST; /*查找成功,返回找到结点的地址*/
}

Position FindMin( BinTree BST )
{
	if( !BST ) return NULL; /*空的二叉搜索树,返回NULL*/ 
    else if( !BST->Left ) 
        return BST;  /*找到最左叶结点并返回*/     
	else         
		return FindMin( BST->Left ); /*沿左分支继续查找*/ 
}

Position FindMax( BinTree BST )
{
	if(BST ) 
		while( BST->Right )  BST = BST->Right; /*沿右分支继续查找,直到最右叶结点*/ 
    return BST;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值