1102 Invert a Binary Tree (25 分) 树的遍历

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1
#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<cctype>
#include<cstdlib>
#include<ctime>
#include<unordered_map>

using namespace std;

struct node {
	int id; //每个结点的id 
	int l;
	int r;
	int index; //下标值 
	int level; //当前层数 
} a[20];

vector<node> v;

void dfs(int root,int index,int level) {
	if(a[root].r != -1) {
		dfs(a[root].r,index * 2 + 2,level + 1);
	}
	v.push_back({root,0,0,index,level});
	if(a[root].l != -1) {
		dfs(a[root].l,index * 2 + 1,level + 1);
	}
}

bool cmp(node a,node b) {
	if(a.level != b.level) {
		return a.level < b.level;
	} else {
		return a.index > b.index;
	}
}

int main() {
	int n = 0;
	int have[20] = {0};
	int root = 0;
	scanf("%d",&n);
	for(int i = 0;i < n;i++) {
		a[i].id = i;
		string l,r;
		cin >> l >> r;
		if(l != "-") {
			a[i].l = stoi(l);
			have[stoi(l)] = 1;
		} else {
			a[i].l = -1;
		}
		if(r != "-") {
			a[i].r = stoi(r);
			have[stoi(r)] = 1;
		} else {
			a[i].r = -1;
		}
	}
	while(have[root] == 1) {
		root++;
	}
	dfs(root,0,0);
	vector<node> v2(v);
	sort(v2.begin(),v2.end(),cmp);
	for(int i = 0;i < v2.size();i++) {
		if(i != 0) {
			printf(" ");
		}
		printf("%d",v2[i].id);
	}
	printf("\n");
	for(int i = 0;i < v.size();i++) {
		if(i != 0) {
			printf(" ");
		}
		printf("%d",v[i].id);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值