HDU-2955 Robberies (01背包)

10 篇文章 0 订阅
4 篇文章 0 订阅

题目:

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.
For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.
His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each
scenario, the first line of input gives a floating point number P, the
probability Roy needs to be below, and an integer N, the number of
banks he has plans for. Then follow N lines, where line j gives an
integer Mj and a floating point number Pj . Bank j contains Mj
millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.
Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

思路:

这题难点在于背包容量和价值如何取,我这里是把最大可抢金额数当作容量, 把(1-被抓概率)即逃跑概率当作价值,因为这样可以往大取。

This is Code:

#include<bits/stdc++.h>
using namespace std;
float dp[15000];

typedef struct{
    int val;
    float cost;
}node;

void zeroonebag(node a, int n){
    for (int i = n; i >= a.val; i--)
        dp[i] = max(dp[i-a.val]*a.cost, dp[i]);
}

int main()
{
    int T, n;
    double P;
    node b[150];
    cin>>T;
    while(T--){
        int maxsum = 0;
        cin>>P>>n;
        memset(dp, 0, sizeof(dp));
        dp[0] = 1;//初始化由于没偷任何东西时逃脱概率为1,其他概率为0
        for (int i = 0; i < n; i++){
            cin>>b[i].val>>b[i].cost;
            b[i].cost = 1 - b[i].cost;
            maxsum += b[i].val;
        }
        for (int i = 0; i < n; i++)
            zeroonebag(b[i], maxsum);
        for (int i = maxsum; i >= 0; i--){
            if (dp[i] >= 1-P){
                cout<<i<<endl;
                break;
            }
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值