ZZULI_SummerPractice(6)  POJ 126…

Time Limit: 1000MSMemory Limit: 10000K64bit IO Format: %I64d & %I64u

[Submit  [Go Back  [Status]

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input


0 0 4 4 0 4 4 0 
5 0 7 6 1 0 2 3 
5 0 7 6 3 -6 4 -3 
2 0 2 27 1 5 18 5 
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT 
POINT 2.00 2.00 
NONE 
LINE 
POINT 2.00 5.00 
POINT 1.07 2.20 
END OF OUTPUT 
发现今天出的计算几何超出了往常所有比赛的总数……,震惊中……,这题题意就是给你两个二维的直线,求他们之间的关系,相交了再求出他们之间的交点,很好求的题,要注意的是求斜率的时候与y轴平行的那条直线要另外讨论(原因我想就不用说了吧),求出斜率和截距后,最后看其关系即可
发现每次比赛的时候代码正确率超高,基本就不用改,吼吼……好高兴ZZULI_SummerPractice(6) <wbr> <wbr>POJ <wbr>1269 <wbr> <wbr>Intersecting <wbr>Lines
代码:
 
   
#include<stdio.h>
#include<math.h>
struct point{
        double x1,x2,x3,x4;
  double y1,y2,y3,y4;
}map[15];
int main()
{
 int n,i,flag1,flag2;
 double k1,k2,b1,b2,x,y;
      scanf("%d",&n);
      for(i=0;i<n;i++)
              scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&map[i].x1,&map[i].y1,&map[i].x2,&map[i].y2,&map[i].x3,&map[i].y3,&map[i].x4,&map[i].y4);
   printf("INTERSECTING LINES OUTPUT\n");
       for(i=0;i<n;i++)
      {
            flag1=flag2=0;
               if(fabs(map[i].x2-map[i].x1)>=1e-10)
          {
            k1=(map[i].y2-map[i].y1)/(map[i].x2-map[i].x1);
              b1=map[i].y1-k1*map[i].x1;
           }
            else{flag1=1;k1=map[i].x2;}
          if(fabs(map[i].x4-map[i].x3)>=1e-10)
          {
            k2=(map[i].y4-map[i].y3)/(map[i].x4-map[i].x3);
              b2=map[i].y3-k2*map[i].x3;
           }
            else {flag2=1;k2=map[i].x3;}
         if(flag1||flag2)
             {
                    if(flag1&&flag2)
                     {
                            if(fabs(k1-k2)<1e-10)
                                 printf("LINE\n");
                            else printf("NONE\n");
                       }
                    else if(flag1&&!flag2)
                       {
                            x=k1;
                                y=k2*x+b2;
                           printf("POINT %.2lf %.2lf\n",x,y);
                   }
                    else{
                                x=k2;
                                y=k1*x+b1;
                           printf("POINT %.2lf %.2lf\n",x,y);
                   }
                    continue;
            }
            if(fabs(k1-k2)<1e-10)
         {
                    if(fabs(b1-b2)<1e-10)
                         printf("LINE\n");
                    else printf("NONE\n");
               }
            else{
                        x=(b2-b1)/(k1-k2);
                   y=k1*x+b1;
                   printf("POINT %.2lf %.2lf\n",x,y);
           }
    }
    printf("END OF OUTPUT\n");
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值