ZZULI 1618 (HDU 1082)Matrix Ch…

Matrix Chain Multiplication

Time Limit:1000MS Memory Limit:65536K
Total Submit:8 Accepted:2

Description

Matrix multiplication problem is a typical example of dynamical programming.

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input

Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line }
Line = Expression
Expression = Matrix | "(" Expression Expression ")"
Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125

Source

 

用栈,原来做过的不知道比赛的时候怎么想的,就不会做了……

 

代码:

#include<stdio.h>

struct multipl{
    int col,row;
}map[27];
int top,stack_col[27],stack_row[27];

int match(int a,int b)
{
    if(stack_col[a] == stack_row[b])
        return 0;
    return 1;
}

int Isalpha(char a)
{
    if(a>='A'&&a<='Z')
        return 1;
    return 0;
}

int main()
{
    int num,n,b,c,i;
    char str[1000],word;
    scanf("%d",&n);
    while(n--){
        getchar();
        scanf("%c %d%d",&word,&b,&c);
        map[word-'A'].col=c;
        map[word-'A'].row=b;
    }
    getchar();
    while(gets(str)){
        num=0;top=0;
        for(i=0;str[i];i++)
        {
            if(Isalpha(str[i]))
            {
                stack_col[top]=map[str[i]-'A'].col;
                stack_row[top++]=map[str[i]-'A'].row;
            }
            else if(str[i]==')')
            {
                if(match(top-2,top-1))
                    break;
                num+=stack_row[top-2]*stack_col[top-2]*stack_col[top-1];
                stack_col[top-2]=stack_col[top-1];
                top--;
            }
        }
        if(str[i])
            printf("error\n");
        else printf("%d\n",num);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值