PAT 1009 Product of Polynomials (25)

22 篇文章 0 订阅

1009 Product of Polynomials (25)(25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​​ aN1​​​​ N2​​ aN2 ... NK​​ aNK

where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

思路:

这道题和1002非常相似。不过我这里不打算用和1002一样的办法,先用vector把第一个多项式的数据记录下来,第二个多项式边输入边计算,计算出来的数据再入vector,然后按照exp从大到小排序,如果有一样的就相加,并且去掉为0的项。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <climits>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>  
#include <set>
using namespace std;

struct num
{
	int exp;
	double coe;
};

vector<num> poly;

bool cmp(const num &a, const num &b)
{
	return a.exp > b.exp;
}

int main()
{
	int k1, k2;
	cin >> k1;
	for (int i = 0; i < k1; i++)
	{
		num t;
		cin >> t.exp >> t.coe;
		poly.push_back(t);
	}
	cin >> k2;
	for (int i = 0; i < k2; i++)
	{
		int n;
		double a;
		cin >> n >> a;
		for (int j = 0; j < k1; j++)
		{
			num t;
			t.exp = poly[j].exp + n;
			t.coe = poly[j].coe * a;
			poly.push_back(t);
		}
	}
	sort(poly.begin() + k1, poly.end(), cmp);
	for (int i = k1; i < poly.size(); i++)
	{
		if (i < poly.size() - 1 && poly[i].exp == poly[i + 1].exp)
		{
			poly[i].coe += poly[i + 1].coe;
			poly.erase(poly.begin() + i + 1);
			if (poly[i].coe == 0)
			{
				poly.erase(poly.begin() + i);
				i--;
			}
			i--;
		}
	}
	cout << poly.size() - k1;
	for (int i = k1; i < poly.size(); i++)
		printf(" %d %.1lf", poly[i].exp, poly[i].coe);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值